icon Top 9 categories map      RocketAware > man pages >

boot(8)

Tips: Browse or Search all pages for efficient awareness of more than 6000 of the most popular reusable and open source applications, functions, libraries, and FAQs.


The "RKT couplings" below include links to source code, updates, additional information, advice, FAQs, and overviews.


Home

Search all pages


Subjects

By activity
Professions, Sciences, Humanities, Business, ...

User Interface
Text-based, GUI, Audio, Video, Keyboards, Mouse, Images,...

Text Strings
Conversions, tests, processing, manipulation,...

Math
Integer, Floating point, Matrix, Statistics, Boolean, ...

Processing
Algorithms, Memory, Process control, Debugging, ...

Stored Data
Data storage, Integrity, Encryption, Compression, ...

Communications
Networks, protocols, Interprocess, Remote, Client Server, ...

Hard World
Timing, Calendar and Clock, Audio, Video, Printer, Controls...

File System
Management, Filtering, File & Directory access, Viewers, ...

    

RocketLink!--> Man page versions: OpenBSD FreeBSD Others



BOOT(8)       OpenBSD System Manager's Manual (I386 Architecture)      BOOT(8)

NAME
     boot - second-stage bootstrap



DESCRIPTION
     The main purpose of this program is to load the system kernel, dealing
     with the downfalls of the PC BIOS architecture.

     As described in boot_i386(8) this program is loaded by the biosboot(8)
     primary bootstrap loader and provides a convenient way to load the ker-
     nel.  This program acts as an enhanced boot monitor for PC systems, pro-
     viding common interface for the kernel to start from.

     Basic operations include:
     -   Detecting and switching between multiple consoles.
     -   Loading kernels from any device supported by your system BIOS.
     -   Loading kernels compressed by gzip(1).
     -   Passing system parameters queried from the BIOS to the kernel.
     -   Providing an interactive command line.

     The sequence of its operation is as follows: initialization, parsing the
     configuration file, then an interactive command line.  While at the com-
     mand line you have 5 seconds to type any commands, if needed. If time ex-
     pires, the kernel will be loaded according to the current variable set-
     tings (See the set command).  Each time a kernel load fails, the timeout
     is increased by one second. The sequence of boot operations is as fol-
     lows:

     1.   Set up a protected mode environment which catches and reports pro-
          cessor exceptions, and provides a simple protected-mode BIOS inter-
          face.

     2.   Probe for console devices, which includes the (default) PC VGA+Key-
          board console (pc0) and up to four serial consoles (com0 through
          com3) connected to the serial ports. Display messages to the default
          console about the devices found.

     3.   Detect memory. Conventional memory is detected by quering the BIOS.
          Extended memory is detected by probing page-by-page through the ad-
          dress space, rather than asking the BIOS; many BIOS cannot report
          larger than 64M of memory.  All the memory found is reported to the
          default console device.

     4.   Probe for APM support in the BIOS. Message printed if support is
          present.

     5.   If the file /etc/boot.conf exists on the filesystem boot was loaded
          from, open and parse it. This file may contain any commands boot ac-
          cepts at the interactive prompt.  Though default settings usually
          suffice, they can be changed here.

     6.   The header line

                OpenBSD BOOT [x.xx]

          is displayed to the active console, where x.xx is a version number
          of the boot program, followed by the

                boot>

          prompt, which means you are in the interactive mode and may enter
          commands. If you do not, boot will proceed loading kernel with the
          current parameters after the timeout period has expired.

COMMANDS
     The following commands are accepted at the boot prompt:

     boot [image [-abcds]]      Boots kernel image specified by the image with
                                options if any. Image specification consists
                                of a pair device: filename, either of each
                                maybe omitted (':' is not needed if both), in
                                which case values from boot variables will be
                                used.

     echo [args]                Displays args on the console device.

     help                       Prints a list of available commands and ma-
                                chine dependant commands, if any.

     machine [subcommand]       Issues machine-dependant commands. These are
                                defined for i386 architecture:

                                cnvmem     Prints/sets the amount of conven-
                                           tional memory.

                                diskinfo   Prints list of hard disks installed
                                           on your system including: BIOS de-
                                           vice number, and the BIOS geometry.

                                extmem     Prints/sets the amount of extended
                                           memory.

                                memory     Prints physical memory map.

                                regs       Prints contents of processor regis-
                                           ters if compiled with DEBUG.

     ls [directory]             Prints contents of the specified directory in
                                long format including: attributes and file
                                type, owner, group, size, filename.

     reboot                     Reboots machine by initiating a warm boot pro-
                                cedure.

     set [varname [value]]      If invoked without arguments, prints a list of
                                variables and their values.  If only varname
                                is specified, displays contents of that vari-
                                able.  If varname and value are both speci-
                                fied, sets that variable to the given value.
                                Variables include:

                                addr     Address at wich to load the kernel.
                                howto    Options to pass to the loaded kernel.
                                debug    Debug flag if boot was compiled with
                                         DEBUG defined.
                                device   Boot device name (ie fd0a, sd0a).
                                tty      Active console device name.
                                image    File name containing the kernel im-
                                         age.

     stty [device [baudrate]]   Displays or sets the baudrate for a console
                                device. If changing speed for the currently
                                active console, gives you five seconds of
                                pause before changing the baud rate to allow
                                you to change your terminal's speed to match.
                                If changing speed not for the active console,
                                sets the baudrate value to be used the next
                                time you switch to a serial console.  The bau-
                                drate value is not used for the pc0 console.


                                The default baudrate if not specifically set
                                is 9600 baud.

     time                       Displays system time and date.

FILES
     /usr/mdec/biosboot    first stage bootstrap
     /boot                 system bootstrap
     /etc/boot.conf        system bootstrap's startup file
     /bsd                  kernel image

SEE ALSO
     boot_i386(8),  fdisk(8),  installboot(8),  gzip(1).

     RFC 1950 describes the zlib library interface.

     The official home page for the version of zlib used in this operating
     system see http://quest.jpl.nasa.gov/zlib/ .

BUGS
     Well, nobody is perfect.

HISTORY
     This program was written by Michael Shalayeff for OpenBSD 2.1.

OpenBSD 2.3                    September 1, 1997                             3

Source: OpenBSD 2.6 man pages. Copyright: Portions are copyrighted by BERKELEY
SOFTWARE DESIGN, INC., The Regents of the University of California, Massachusetts
Institute of Technology, Free Software Foundation, FreeBSD Inc., and others.



(Corrections, notes, and links courtesy of RocketAware.com)


[Detailed Topics]


[Overview Topics]



RocketLink!--> Man page versions: OpenBSD FreeBSD Others






Rapid-Links: Search | About | Comments | Submit Path: RocketAware > man pages > boot.8/
RocketAware.com is a service of Mib Software
Copyright 1999, Forrest J. Cavalier III. All Rights Reserved.
We welcome submissions and comments