icon Top 9 categories map      RocketAware > man pages >

boot_config(8)

Tips: Browse or Search all pages for efficient awareness of more than 6000 of the most popular reusable and open source applications, functions, libraries, and FAQs.


The "RKT couplings" below include links to source code, updates, additional information, advice, FAQs, and overviews.


Home

Search all pages


Subjects

By activity
Professions, Sciences, Humanities, Business, ...

User Interface
Text-based, GUI, Audio, Video, Keyboards, Mouse, Images,...

Text Strings
Conversions, tests, processing, manipulation,...

Math
Integer, Floating point, Matrix, Statistics, Boolean, ...

Processing
Algorithms, Memory, Process control, Debugging, ...

Stored Data
Data storage, Integrity, Encryption, Compression, ...

Communications
Networks, protocols, Interprocess, Remote, Client Server, ...

Hard World
Timing, Calendar and Clock, Audio, Video, Printer, Controls...

File System
Management, Filtering, File & Directory access, Viewers, ...

    

RocketLink!--> Man page versions: OpenBSD



boot_config(8)          OpenBSD System Manager's Manual         boot_config(8)

NAME
     boot_config - how to change kernel configuration at boot



DESCRIPTION
     BOOT_CONFIG is a kernel option that make it possible to change the con-
     figuration at boot time.

     The boot time configuration is invokes by a -c option when OpenBSD ask
     for kernel to boot.

     >> OpenBSD BOOT 640/31744 k [1.29]
     use ? for file list, or carriage return for defaults
     use hd(1,a)/bsd to boot sd0 when sd0 is also installed
     Boot: [[[wd(0,a)]/bsd][-abcdrs]] : -c\n
     Booting.. blah blah blah
     avail mem = 28188672
     using 430 buffers containing 1761280 bytes of memory
     User Kernel Config
     UKC>

COMMANDS
     add dev            Add a device through copying another.

     base 8|10|16       Change the base for large numbers. E.g. I/O addresses
                        in a VAXen are octal.

     change devno|dev   Modify one or more devices.

     disable devno|dev  Disable one or more devices.

     enable devno|dev   Enable one or more devices.

     exit               Continue boot.

     find devno|dev     Find one or more devices.

     help               Give a short summary of all commands and its argu-
                        ments.

     list               Show all known devices a screen at the time.

     lines [count]      Setup the number of rows per page.

     quit               Continue boot.

     show [attr [val]]  Show devices with an attribute and optional with a
                        specified value.

EXAMPLES
     Your ethernet card isn't found at boot because the configuration don't
     match the hardware. E.g. wrong IRQ in OpenBSD/i386. You know that your
     ethernet card is using the eddriver.

     UKC> find ed\n
     81 ed0 at isa0 port 0x280 size 0 iomem 0xd0000 iosiz 0 irq 9 drq -1 pnpid -1
     82 ed1 at isa0 port 0x250 size 0 iomem 0xd8000 iosiz 0 irq 9 drq -1 pnpid -1
     83 ed2 at isa0 port 0x300 size 0 iomem 0xcc000 iosiz 0 irq 10 drq -1 pnpid -1
     84 ed* at pcmcia0 port 0x300 size 0x20 iomem -1 iosiz 0 irq 10 drq -1 slot -1
     UKC>

     Ok, ed2 seems to match the configuration except IRQ 5 instead of IRQ 10.
     So change irq on ed2 with the change command. Specify device by name or
     number.

     UKC> change ed2\n
     83 E ed2 at isa0 port 0x300 size 0 iomem 0xcc000 iosiz 0 irq 10 drq -1 pnpid -1
     change (y/n) ? y\n
     port [0x300] ? \n
     size [0] ? \n
     iomem [0xcc000] ? \n
     iosiz [0] ? \n
     irq [10] ? 5\n
     drq [-1] ? \n
     pnpid [-1] ? \n
     83 ed2 changed
     83 ed2 at isa0 port 0x300 size 0 iomem 0xcc000 iosiz 0 irq 5 drq -1 pnpid -1
     UKC>

     Another case is when a none existing device is wrongly found when another
     device is found at the probed location. One known case is the Mitsumi
     none ATAPI cdrom in OpenBSD/i386. The simplest thing to solve that prob-
     lem is to disable mcd0.

     UKC> find mcd0\n
      29 mcd0 at isa0 port 0x300 size 0 iomem -1 iosiz 0 irq 10 drq -1 pnpid -1
     UKC> disable mcd0\n
      29 mcd0 disabled
     UKC> find 29\n
      29 mcd0 at isa0 disable port 0x300 size 0 iomem -1 iosiz 0 irq 10 drq -1 pnpid -1

     The show command is useful for finding which devices has a certain at-
     tribute.  It can even show us all devices with an certain value of the
     attribute.

     UKC> show slot\n
       1 ahc* at eisa0 slot -1
       3 ep0 at eisa0 slot -1
       6 ep* at eisa0 slot -1
       8 ep* at pcmcia* port 0x300 size 0x10 iomem -1 iosiz 0 irq 10 drq -1 slot -1
      40 com3 at pcmcia* port 0x2e8 size 8 iomem -1 iosiz 0 irq 3 drq -1 slot -1
      84 ed* at pcmcia* port 0x300 size 0x20 iomem -1 iosiz 0 irq 10 drq -1 slot -1
      86 ahb* at eisa0 slot -1
      87 fea* at eisa0 slot -1
     UKC> show port 0x300\n
       8 ep* at pcmcia* port 0x300 size 0x10 iomem -1 iosiz 0 irq 10 drq -1 slot -1
      29 mcd0 at isa0 port 0x300 size 0 iomem -1 iosiz 0 irq 10 drq -1 pnpid -1
      31 wt0 at isa0 port 0x300 size 0 iomem -1 iosiz 0 irq 5 drq 1 pnpid -1
      58 el0 at isa0 port 0x300 size 0 iomem -1 iosiz 0 irq 9 drq -1 pnpid -1
      60 ie1 at isa0 port 0x300 size 0 iomem -1 iosiz 0 irq 10 drq -1 pnpid -1
      83 ed2 at isa0 port 0x300 size 0 iomem 0xcc000 iosiz 0 irq 10 drq -1 pnpid -1
      84 ed* at pcmcia* port 0x300 size 0x20 iomem -1 iosiz 0 irq 10 drq -1 slot -1
     UKC>

     It is possible to add devices, but only devices that already exists in
     the kernel. If a device is added all devices after is renumbered.

     UKC> find ep\n
       2 ep0 at isa0 port -1 size 0 iomem -1 iosiz 0 irq -1 drq -1 pnpid -1
       3 ep0 at eisa0 slot -1
       4 ep0 at pci0|pci* dev -1 function -1
       5 ep* at isa0 port -1 size 0 iomem -1 iosiz 0 irq -1 drq -1 pnpid -1
       6 ep* at eisa0 slot -1
       7 ep* at pci0|pci* dev -1 function -1
       8 ep* at pcmcia* port 0x300 size 0x10 iomem -1 iosiz 0 irq 10 drq -1 slot -1
     UKC> add ep1\n
     Clone Device (DevNo, 'q' or '?') ? 4
     Insert before Device (DevNo, 'q' or '?') ? 5
       5 ep1 at pci0|pci* dev -1 function -1
     UKC> change 5\n
       5 ep1 at pci0|pci* dev -1 function -1
     change (y/n) ?\n
     dev [-1] ? 14\n
     function [-1] ? \n
       5 ep1 changed
       5 ep1 at pci0|pci* dev 14 function -1
     UKC>

     And to continuing boot try quit or exit...

     UKC> quit\n
     Continuing...
     mainbus0 (root)

BUGS
     The add command is rather restricted. Might be fixed in the future.

AUTHOR
     Mats O Jansson <moj@stacken.kth.se>

4th Berkeley Distribution     September 21, 1996                             3

Source: OpenBSD 2.6 man pages. Copyright: Portions are copyrighted by BERKELEY
SOFTWARE DESIGN, INC., The Regents of the University of California, Massachusetts
Institute of Technology, Free Software Foundation, FreeBSD Inc., and others.



(Corrections, notes, and links courtesy of RocketAware.com)


[Detailed Topics]


[Overview Topics]



RocketLink!--> Man page versions: OpenBSD






Rapid-Links: Search | About | Comments | Submit Path: RocketAware > man pages > boot_config.8/
RocketAware.com is a service of Mib Software
Copyright 1999, Forrest J. Cavalier III. All Rights Reserved.
We welcome submissions and comments