icon Top 9 categories map      RocketAware > man pages >

mount_procfs(8)

Tips: Browse or Search all pages for efficient awareness of more than 6000 of the most popular reusable and open source applications, functions, libraries, and FAQs.


The "RKT couplings" below include links to source code, updates, additional information, advice, FAQs, and overviews.


Home

Search all pages


Subjects

By activity
Professions, Sciences, Humanities, Business, ...

User Interface
Text-based, GUI, Audio, Video, Keyboards, Mouse, Images,...

Text Strings
Conversions, tests, processing, manipulation,...

Math
Integer, Floating point, Matrix, Statistics, Boolean, ...

Processing
Algorithms, Memory, Process control, Debugging, ...

Stored Data
Data storage, Integrity, Encryption, Compression, ...

Communications
Networks, protocols, Interprocess, Remote, Client Server, ...

Hard World
Timing, Calendar and Clock, Audio, Video, Printer, Controls...

File System
Management, Filtering, File & Directory access, Viewers, ...

    

RocketLink!--> Man page versions: OpenBSD NetBSD



MOUNT_PROCFS(8)         OpenBSD System Manager's Manual        MOUNT_PROCFS(8)

NAME
     mount_procfs - mount the process file system



SYNOPSIS
     mount_procfs [-o options] /proc mount_point

DESCRIPTION
     The mount_procfs command attaches an instance of the process namespace to
     the global filesystem namespace.  The conventional mount point is /proc.
     This command is normally executed by mount(8) at boot time.

     The options are as follows:

     -o      Options are specified with a -o flag followed by a comma separat-
             ed string of options.  See the mount(8) man page for possible op-
             tions and their meanings.

     The root of the process filesystem contains an entry for each active pro-
     cess.  These processes are visible as a directory whose name is the pro-
     cess' pid.  In addition, the special entry curproc references the current
     process.

     Each directory contains several files.

     ctl     a writeonly file which supports a variety of control operations.
             Control commands are written as strings to the ctl file.  The
             control commands are:
             attach  stops the target process and arranges for the sending
                     process to become the debug control process.
             detach  continue execution of the target process and remove it
                     from control by the debug process (which need not be the
                     sending process).
             run     continue running the target process until a signal is de-
                     livered, a breakpoint is hit, or the target process ex-
                     its.
             step    single step the target process, with no signal delivery.
             wait    wait for the target process to come to a steady state
                     ready for debugging.  The target process must be in this
                     state before any of the other commands are allowed.

             The string can also be the name of a signal, lower case and with-
             out the SIG prefix, in which case that signal is delivered to the
             process (see sigaction(2)).

     file    A reference to the vnode from which the process text was read.
             This can be used to gain access to the process' symbol table, or
             to start another copy of the process.

     mem     The complete virtual memory image of the process.  Only those ad-
             dress which exist in the process can be accessed.  Reads and
             writes to this file modify the process.  Writes to the text seg-
             ment remain private to the process.

     note    Not implemented.

     notepg  Not implemented.

     regs    Allows read and write access to the process' register set.  This
             file contains a binary data structure struct regs defined in
             <machine/reg.h>. regs can only be written when the process is
             stopped.

     fpregs  The floating point registers as defined by struct fpregs in
             <machine/reg.h>. fpregs is only implemented on machines which
             have distinct general purpose and floating point register sets.

     status  The process status.  This file is readonly and returns a single
             line containing multiple space-separated fields as follows:

             -   command name
             -   process id
             -   parent process id
             -   process group id
             -   session id
             -   major,minor of the controlling terminal, or -1,-1 if there is
                 no controlling terminal.
             -   a list of process flags: ctty if there is a controlling ter-
                 minal, sldr if the process is a session leader, noflags if
                 neither of the other two flags are set.
             -   the process start time in seconds and microseconds, comma
                 separated.
             -   the user time in seconds and microseconds, comma separated.
             -   the system time in seconds and microseconds, comma separated.
             -   the wait channel message
             -   the process credentials consisting of the effective user id
                 and the list of groups (whose first member is the effective
                 group id) all comma separated.

     In a normal debugging environment, where the target is fork/exec'd by the
     debugger, the debugger should fork and the child should stop itself (with
     a self-inflicted SIGSTOP for example).  The parent should issue a wait
     and then an attach command via the appropriate ctl file.  The child pro-
     cess will receive a SIGTRAP immediately after the call to exec (see
     execve(2)).

FILES
     /proc/#
     /proc/curproc
     /proc/curproc/ctl
     /proc/curproc/file
     /proc/curproc/mem
     /proc/curproc/note
     /proc/curproc/notepg
     /proc/curproc/regs
     /proc/curproc/fpregs
     /proc/curproc/status

SEE ALSO
     sigaction(2),  mount(2),  unmount(2)

CAVEATS
     This filesystem may not be NFS-exported since most of the functionality
     of procfs requires that state be maintained.

HISTORY
     The mount_procfs utility first appeared in 4.4BSD.

4.4BSD                          March 27, 1994                               2

Source: OpenBSD 2.6 man pages. Copyright: Portions are copyrighted by BERKELEY
SOFTWARE DESIGN, INC., The Regents of the University of California, Massachusetts
Institute of Technology, Free Software Foundation, FreeBSD Inc., and others.



(Corrections, notes, and links courtesy of RocketAware.com)


[Detailed Topics]
OpenBSD sources for mount_procfs(8)


[Overview Topics]

Up to: Specific Types of File Systems - Specific forms of file systems. DFS, NFS, MS-DOS, etc.
Up to: File System Operations - Operations for entire file-systems (quotas, configuration, consistency, mount, unmount, et al)


RocketLink!--> Man page versions: OpenBSD NetBSD






Rapid-Links: Search | About | Comments | Submit Path: RocketAware > man pages > mount_procfs.8/
RocketAware.com is a service of Mib Software
Copyright 1999, Forrest J. Cavalier III. All Rights Reserved.
We welcome submissions and comments