icon Top 9 categories map      RocketAware > man pages >

route(8)

Tips: Browse or Search all pages for efficient awareness of more than 6000 of the most popular reusable and open source applications, functions, libraries, and FAQs.


The "RKT couplings" below include links to source code, updates, additional information, advice, FAQs, and overviews.


Home

Search all pages


Subjects

By activity
Professions, Sciences, Humanities, Business, ...

User Interface
Text-based, GUI, Audio, Video, Keyboards, Mouse, Images,...

Text Strings
Conversions, tests, processing, manipulation,...

Math
Integer, Floating point, Matrix, Statistics, Boolean, ...

Processing
Algorithms, Memory, Process control, Debugging, ...

Stored Data
Data storage, Integrity, Encryption, Compression, ...

Communications
Networks, protocols, Interprocess, Remote, Client Server, ...

Hard World
Timing, Calendar and Clock, Audio, Video, Printer, Controls...

File System
Management, Filtering, File & Directory access, Viewers, ...

    

RocketLink!--> Man page versions: OpenBSD FreeBSD NetBSD Others



ROUTE(8)                OpenBSD System Manager's Manual               ROUTE(8)

NAME
     route - manually manipulate the routing tables.



SYNOPSIS
     route [-dnqv] command [[modifiers] args]

DESCRIPTION
     Route is a utility used to manually manipulate the network routing ta-
     bles.  It normally is not needed, as a system routing table management
     daemon such as routed(8),  should tend to this task.

     The route: utility supports a limited number of general options, but a
     rich command language, enabling the user to specify any arbitrary request
     that could be delivered via the programmatic interface discussed in
     route(4).

     -d      Run in debug-only mode, i.e. don't actually modify the routing
             table.

     -n      Bypasses attempts to print host and network names symbolically
             when reporting actions.  (The process of translating between sym-
             bolic names and numerical equivalents can be quite time consum-
             ing, and may require correct operation of the network; thus it
             may be expedient to forgo this, especially when attempting to re-
             pair networking operations).

     -v      (verbose) Print additional details.

     -q      Suppress all output.

     The route: utility provides several commands:

     add         Add a route.
     flush       Remove all routes.
     delete      Delete a specific route.
     change      Change aspects of a route (such as its gateway).
     get         Lookup and display the route for a destination.
     show        Print out the route table similar to "netstat -r" (see
                 netstat(8)).
     monitor     Continuously report any changes to the routing information
                 base, routing lookup misses, or suspected network partition-
                 ings.

     The monitor command has the syntax

           route [-n] monitor

     The flush command has the syntax

           route [-n] flush [family]

     If the flush command is specified, route will ``flush'' the routing ta-
     bles of all gateway entries.  When the address family may is specified by
     any of the -osi, -xns, -encap, or -inet modifiers, only routes having
     destinations with addresses in the delineated family will be deleted.

     The other commands have the following syntax:

           route [-n] command [-net | -host] destination gateway

     where destination is the destination host or network, gateway is the
     next-hop intermediary via which packets should be routed.  Routes to a
     particular host may be distinguished from those to a network by inter-
     preting the Internet address specified as the destination argument. The
     optional modifiers -net and -host force the destination to be interpreted
     as a network or a host, respectively.  Otherwise, if the destination has
     a ``local address part'' of INADDR_ANY , or if the destination is the
     symbolic name of a network, then the route is assumed to be to a network;
     otherwise, it is presumed to be a route to a host.

     For example, 128.32 is interpreted as -host 128.0.0.32; 128.32.130 is in-
     terpreted as -host 128.32.0.130; -net 128.32 is interpreted as
     128.32.0.0; and -net 128.32.130 is interpreted as 128.32.130.0. A more
     detailed syntax is also available, for example net 192.168.64.0/20 is in-
     terpreted to specify that the high 20 bits of the address 192.168.64.0
     are the requested network.

     If the destination is directly reachable via an interface requiring no
     intermediary system to act as a gateway, the -interface modifier should
     be specified; the gateway given is the address of this host on the common
     network, indicating the interface to be used for transmission.

     The optional modifiers -xns, -osi, and -link specify that all subsequent
     addresses are in the XNS OSI address families, or are specified as link-
     level addresses, and the names must be numeric specifications rather than
     symbolic names.

     The optional -netmask qualifier is intended to achieve the effect of an
     OSI ESIS redirect with the netmask option, or to manually add subnet
     routes with netmasks different from that of the implied network interface
     (as would otherwise be communicated using the OSPF or ISIS routing proto-
     cols).  One specifies an additional ensuing address parameter (to be in-
     terpreted as a network mask).  The implicit network mask generated in the
     AF_INET case can be overridden by making sure this option follows the
     destination parameter.

     Routes have associated flags which influence operation of the protocols
     when sending to destinations matched by the routes.  These flags may be
     set (or sometimes cleared) by indicating the following corresponding mod-
     ifiers:

     -cloning   RTF_CLONING    - generates a new route on use
     -xresolve  RTF_XRESOLVE   - emit mesg on use (for external lookup)
     -iface    ~RTF_GATEWAY    - destination is directly reachable
     -static    RTF_STATIC     - manually added route
     -nostatic ~RTF_STATIC     - pretend route added by kernel or daemon
     -reject    RTF_REJECT     - emit an ICMP unreachable when matched
     -blackhole RTF_BLACKHOLE  - silently discard pkts (during updates)
     -proto1    RTF_PROTO1     - set protocol specific routing flag #1
     -proto2    RTF_PROTO2     - set protocol specific routing flag #2
     -llinfo    RTF_LLINFO     - validly translates proto addr to link addr

     The optional modifiers -rtt, -rttvar, -sendpipe, -recvpipe, -mtu,
     -hopcount, -expire, and -ssthresh provide initial values to quantities
     maintained in the routing entry by transport level protocols, such as TCP
     or TP4.  These may be individually locked by preceding each such modifier
     to be locked by the -lock meta-modifier, or one can specify that all en-
     suing metrics may be locked by the -lockrest meta-modifier.

     In a change or add command where the destination and gateway are not suf-
     ficient to specify the route (as in the ISO case where several interfaces
     may have the same address), the -ifp or -ifa modifiers may be used to de-
     termine the interface or interface address.

     All symbolic names specified for a destination or gateway are looked up
     first as a host name using gethostbyname(3).  If this lookup fails, get-
     netbyname(3) is then used to interpret the name as that of a network.


     Route uses a routing socket and the new message types RTM_ADD,
     RTM_DELETE, RTM_GET, and RTM_CHANGE.  As such, only the super-user may
     modify the routing tables.

DIAGNOSTICS
     add [host | network ] %s: gateway %s flags %x
             The specified route is being added to the tables.  The values
             printed are from the routing table entry supplied in the ioctl(2)
             call.  If the gateway address used was not the primary address of
             the gateway (the first one returned by gethostbyname(3)),  the
             gateway address is printed numerically as well as symbolically.

     delete [ host &| network ] %s: gateway %s flags %x
             As above, but when deleting an entry.

     %s %s done
             When the flush command is specified, each routing table entry
             deleted is indicated with a message of this form.

     Network is unreachable
             An attempt to add a route failed because the gateway listed was
             not on a directly-connected network.  The next-hop gateway must
             be given.

     not in table
             A delete operation was attempted for an entry which wasn't pre-
             sent in the tables.

     routing table overflow
             An add operation was attempted, but the system was low on re-
             sources and was unable to allocate memory to create the new en-
             try.

SEE ALSO
     netintro(4),  route(4),  esis(4),  routed(8),  XNSrouted(8) IPXrouted(8)

HISTORY
     The route command appeared in 4.2BSD.

BUGS
     The first paragraph may have slightly exaggerated routed's  abilities.

4.4BSD                          March 19, 1994                               3

Source: OpenBSD 2.6 man pages. Copyright: Portions are copyrighted by BERKELEY
SOFTWARE DESIGN, INC., The Regents of the University of California, Massachusetts
Institute of Technology, Free Software Foundation, FreeBSD Inc., and others.



(Corrections, notes, and links courtesy of RocketAware.com)


[Detailed Topics]
FreeBSD Sources for route(8)
OpenBSD sources for route(8)


[Overview Topics]

Up to: Routing - Implementation of routing for communications and networking


RocketLink!--> Man page versions: OpenBSD FreeBSD NetBSD Others






Rapid-Links: Search | About | Comments | Submit Path: RocketAware > man pages > route.8/
RocketAware.com is a service of Mib Software
Copyright 1999, Forrest J. Cavalier III. All Rights Reserved.
We welcome submissions and comments